Were upgrading from NG 12 -> 16 and "@ng-bootstrap/ng-bootstrap getting : Package...

Discussão em 'Angular' iniciado por g. Skud, Junho 24, 2025.

  1. g. Skud

    g. Skud Guest

    When going from 12 -> 13 (eventually 13). perhttps://update.angular.io/?v=12.0-13.0


    ng update @angular/core@13 @angular/cli@13
    ​

    Were getting dependency errors:


    • Package "@ng-bootstrap/ng-bootstrap" has an incompatible peer dependency to "@angular/common" (requires "^11.0.0" (extended), would install "13.4.0").
      Package "@ng-bootstrap/ng-bootstrap" has an incompatible peer dependency to "@angular/core" (requires "^11.0.0" (extended), would install "13.4.0").
      Package "@ng-bootstrap/ng-bootstrap" has an incompatible peer dependency to "@angular/forms" (requires "^11.0.0" (extended), would install "13.4.0").
      Package "@ng-bootstrap/ng-bootstrap" has an incompatible peer dependency to "@angular/localize" (requires "^11.0.0" (extended), would install "13.4.0").
      Package "@ng-bootstrap/ng-bootstrap" has an incompatible peer dependency to "rxjs" (requires "^6.5.5", would install "7.8.1").

    We reviewed the Dependencies table at https://www.npmjs.com/package/@ng-bootstrap/ng-bootstrap#demo

    and upgraded to ^14.1.0, which created more errors. What is the recommended way to do this. Were considering removing @ng-bootstrap/ng-bootstrap from our package.json and manually upgrading as the maintainers don't seem to support peer deps for upgrade steps.

    Continue reading...

Compartilhe esta Página