[Python] Python Library dependency issue when trying to upgrade openssl due to Cryptography

Discussão em 'Python' iniciado por Stack, Julho 18, 2025.

  1. Stack

    Stack Membro Participativo

    I want to upgrade openssl latest package 3.5.1 in a Miniconda python virtual environment in the Centos OS. So I tried below command

    conda update openssl


    output for above cmd

    conda update openssl
    Platform: linux-64
    Collecting package metadata (repodata.json): done
    Solving environment: done

    # All requested packages already installed.


    However, when I checked the Openssl version, it's still reflecting the older version as below

    openssl version


    OpenSSL 1.1.1w 11 Sep 2023

    So I did below conda install cmd to check the dependency issue

    conda install openssl==3.5.1


    below is the output

    Platform: linux-64
    Collecting package metadata (repodata.json): done
    Solving environment: failed

    LibMambaUnsatisfiableError: Encountered problems while solving:
    - package cryptography-37.0.2-py310h597c629_0 requires openssl >=1.1.1o,<1.1.2a, but none of the providers can be installed

    Could not solve for environment specs
    The following packages are incompatible
    ├─ cryptography ==37.0.2 * is installable with the potential options
    │ ├─ cryptography 37.0.2 would require
    │ │ └─ openssl >=1.1.1o,<1.1.2a *, which can be installed;
    │ ├─ cryptography 37.0.2 would require
    │ │ └─ python >=3.7,<3.8.0a0 *, which can be installed;
    │ ├─ cryptography 37.0.2 would require
    │ │ └─ python >=3.8,<3.9.0a0 *, which can be installed;
    │ └─ cryptography 37.0.2 would require
    │ └─ python >=3.9,<3.10.0a0 *, which can be installed;
    ├─ openssl ==3.5.1 * is not installable because it conflicts with any installable versions previously reported;
    └─ pin on python =3.10 * is not installable because it requires
    └─ python =3.10 *, which conflicts with any installable versions previously reported.



    I verified the Cryptography librbary and the version is 45.0.5 But still Openssl install is having above dependency issue. Please suggest how to overcome this issue. thanks.

    Continue reading...

Compartilhe esta Página