1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Anuncie Aqui
    Anuncie aqui você Também: fdantas@4each.com.br

npm install esbuild-* unsupported warning

Discussão em 'Angular' iniciado por Behnam Aminazad, Setembro 25, 2024.

  1. I just upgraded my angular from 10 to 12 from https://update.angular.io/?l=3&v=10.0-12.0 and every step was successful and now npm install is giving bellow warnings:

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-darwin-arm64@0.13.4 (node_modules/esbuild-darwin-arm64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-darwin-arm64@0.13.4: wanted {"os":"darwin","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-freebsd-arm64@0.13.4 (node_modules/esbuild-freebsd-arm64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-freebsd-arm64@0.13.4: wanted {"os":"freebsd","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-android-arm64@0.13.4 (node_modules/esbuild-android-arm64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-android-arm64@0.13.4: wanted {"os":"android","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-arm@0.13.4 (node_modules/esbuild-linux-arm):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-arm@0.13.4: wanted {"os":"linux","arch":"arm"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-64@0.13.4 (node_modules/esbuild-linux-64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-64@0.13.4: wanted {"os":"linux","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-32@0.13.4 (node_modules/esbuild-linux-32):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-32@0.13.4: wanted {"os":"linux","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-arm64@0.13.4 (node_modules/esbuild-linux-arm64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-arm64@0.13.4: wanted {"os":"linux","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-ppc64le@0.13.4 (node_modules/esbuild-linux-ppc64le):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-ppc64le@0.13.4: wanted {"os":"linux","arch":"ppc64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-linux-mips64le@0.13.4 (node_modules/esbuild-linux-mips64le):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-linux-mips64le@0.13.4: wanted {"os":"linux","arch":"mips64el"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-openbsd-64@0.13.4 (node_modules/esbuild-openbsd-64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-openbsd-64@0.13.4: wanted {"os":"openbsd","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-sunos-64@0.13.4 (node_modules/esbuild-sunos-64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-sunos-64@0.13.4: wanted {"os":"sunos","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-freebsd-64@0.13.4 (node_modules/esbuild-freebsd-64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-freebsd-64@0.13.4: wanted {"os":"freebsd","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-windows-64@0.13.4 (node_modules/esbuild-windows-64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-windows-64@0.13.4: wanted {"os":"win32","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-windows-32@0.13.4 (node_modules/esbuild-windows-32):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-windows-32@0.13.4: wanted {"os":"win32","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: esbuild-windows-arm64@0.13.4 (node_modules/esbuild-windows-arm64):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for esbuild-windows-arm64@0.13.4: wanted {"os":"win32","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})


    here is my package.json:

    {
    ...
    "resolutions": {
    "webpack": "^5.0.0"
    },
    "dependencies": {
    "@angular/animations": "~12.2.10",
    "@angular/common": "~12.2.10",
    "@angular/compiler": "~12.2.10",
    "@angular/core": "~12.2.10",
    "@angular/forms": "~12.2.10",
    "@angular/localize": "^12.2.10",
    "@angular/platform-browser": "~12.2.10",
    "@angular/platform-browser-dynamic": "~12.2.10",
    "@angular/platform-server": "~12.2.10",
    "@angular/router": "~12.2.10",
    "@nguniversal/express-engine": "^12.1.1",
    ...
    }
    }


    I searched the error but couldn't find any solution

    any idea how to fix these warnings?

    Continue reading...

Compartilhe esta Página